Farewell Joomla 1.5

We are happy to announce the 1.0 stable release of our EXTman, FILEman and LOGman extensions.

The releases are focussed on stability and do not include any new features. Together with these stable releases we are also ending development on Joomla 1.5. The upcoming 2.0 versions will no longer support Joomla 1.5.

Ending Joomla 1.5 compatibility

Joomla 1.5 was released on January 2008 and lived a happy life for years. But all good things come to an end. The Joomla team stopped supporting Joomla 1.5 on September 2012.

We have kept Joomla 1.5 support on all our components until now to give our customers a longer migration period.

With the 1.0 stable releases of all our extensions we are concluding support for Joomla 1.5. All our future development will be focused on Joomla 2.5 and 3.x only.

Where we go from here

In a next step LOGman, FILEman and EXTman, will get a major version increase to 2.0.

All our 2.0 extensions will be driven by the next iteration of our Joomlatools Framework, being 2.0. We are doing final refactoring on the framework at the moment before freezing its API’s. Since all our extensions use it, we can at present only release all of them together. Work is well underway for this.

We are also working hard on giving all our components responsive and mobile ready layouts and we are packing them with a bunch of additional usability improvements. You can already find sneak peeks of the changes in some of our previous blog posts.

Up next

How to link to a page in a pdf file.

How to link to a given page in a PDF file when rendered in the browser.

Read more →

Switching from WordPress to Joomla and setting up a document repository

Demistifying the switch from WordPress to Joomla and DOCman

Read more →

How Meltdown and Spectre affects your Joomla site

Here's what we learned so far about the Meltdown and Spectre vulnerabilities.

Read more →