DOCman Security Announcement

Joomlatools would like to announce the immediate availability of DOCman 1.5.8 and DOCman 1.4.1.

Recently a medium level vulnerability was discovered in DOCman. A user with editing permissions can potentially access confidential data. The following versions of DOCman are affected: 1.3.x, 1.4.x up to 1.4.0.stable, 1.5.x up to 1.5.7. Upgrading to either 1.4.1 or 1.5.8 resolves the issue.

Even though this is only a medium level vulnerability that will only affect a small percentage of sites, we recommend everybody to upgrade as soon as possible.

Update

DOCman 1.x is no longer supported, and will not receive bug fixes & security updates.

Upgrading to DOCman 2.x is painless and preserves your data. You will get updates, as well technical support. And of course you are supporting a quality GPL-licensed Joomla extension!

Up next

How to link to a page in a pdf file.

How to link to a given page in a PDF file when rendered in the browser.

Read more →

Switching from WordPress to Joomla and setting up a document repository

Demistifying the switch from WordPress to Joomla and DOCman

Read more →

How Meltdown and Spectre affects your Joomla site

Here's what we learned so far about the Meltdown and Spectre vulnerabilities.

Read more →